工学1号馆

home

HDOJ 1005 Number Sequence

Wu Yudong    August 19, 2018     HDOJ   581   

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n 
on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end 
of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

思路:对于公式 f[n] = A * f[n-1] + B * f[n-2]; 因为对于f[n-1] 或者 f[n-2] 的取值只有 0,1,2,3,4,5,6 这7个数,A,B又是固定的,所以就只有7 * 7 = 49 种可能。由该关系式得知每一项只与前两项发生关系,所以当连续的两项在前面出现过循环节出现了,注意循环节并不一定会是开始的 1,1 。 又因为一组测试数据中f[n]只有49中可能的答案,最坏的情况是所有的情况都遇到了,那么那也会在50次运算中产生循环节。找到循环节后,就可以轻松解决了。

#include <stdio.h>
#include<math.h>

int main()
{
	int a, b, i;
	long n, num[50];
	num[1] = num[2] = 1;
	while (scanf("%d %d %ld", &a, &b, &n), a + b + n) {
		for (i = 3; i <= 48; i++)
			num[i % 48] = (a * num[i - 1] + b * num[i - 2]) % 7;
		printf("%ld\n", num[n % 48]);
	}
	return 0;
}

如果文章对您有帮助,欢迎点击下方按钮打赏作者

Comments

No comments yet.
To verify that you are human, please fill in "七"(required)