工学1号馆

home

« | 返回首页 | »

安装tp5.20

By Wu Yudong on July 10, 2018

今天安装tp5.20的时候出现问题,我这里使用的是将tp直接解压缩后放在项目里面,结果提示下面的错误:
Warning: require(D:\workspace\zhiyuedu\vendor/topthink/think-helper/src/helper.php): failed to open stream: No such file or directory in D:\workspace\zhiyuedu\thinkphp\library\think\Loader.php on line 676

Fatal error: require(): Failed opening required 'D:\workspace\zhiyuedu\vendor/topthink/think-helper/src/helper.php' (include_path='C:\xampp\php\PEAR') in D:\workspace\zhiyuedu\thinkphp\library\think\Loader.php on line 676

后来阅读了官方文档后才发现,需要使用git或者composer来安装

这里使用的是windows下的composer安装

步骤如下:

使用cmd进入命令界面

输入命令:

composer config -g repo.packagist composer https://packagist.phpcomposer.com

接着切换到你的目标目录

输入命令:

composer create-project topthink/think=5.0.*  tp5  --prefer-dist

这里就会自动下载一个名字为tp5的项目文件夹,版本为tp5的最新版,这里即为tp5.20版

如果文章对您有帮助,欢迎点击下方按钮打赏作者

Comments

No comments yet.
To verify that you are human, please fill in "七"(required)